Eclipse Update Site (requires Eclipse 3.3 or 3.4)

Welcome to the Cusp Eclipse Update Site

This site contains feature and plug-in versions for Eclipse, published in the form expected by the Eclipse Update Manager. Use the Update Manager's Feature Updates view to open this site (http://www.sergeykolos.com/cusp/update) to locate new and updated Eclipse feature versions to download.

This site is still experimental. If you encounter problems please report them by creating a ticket in Cusp Trac or posting a message to Cusp Development (google group)

Available Features and Plugins

featureversion
cusp0.9.360 (tested with sbcl 1.0.19-20)
cusp0.9.245 (tested with sbcl 1.0.13-19)
cusp0.9.218 (tested with sbcl 1.0.13-15)
subfeature (optional)version
libraries1.1.0
libraries1.0.0

Manual Installation

1. Download most recent zip file from archive folder

2. Extract contents of the archive into your Eclipse directory.

Automatic Installation

Note: Eclipse 3.4 has new update manager, so you'll need to modify these steps as needed. In the end Eclipse 3.4 will report that its new manager cannot use this update site and will propose to use old update manager. Agree to use the old manager and then follow the instructions below.

1. Start Eclipse and choose the menu 'Help/Software Update/Find and Install'. Select the checkbox 'Search for new features to install' and press the 'Next' button.

2. From the dialog 'Update sites to visit' press the button 'Add update site' or 'New Remote Site'.

3. Enter "Cusp update site" in the 'Name' field and the value 'http://www.sergeykolos.com/cusp/update' into the 'URL' field of the 'New Update Site' dialog. Press the OK button.

4. Expand 'Cusp update site', select the checkbox 'Cusp' and press the 'Next' button.

5. Accept the license agreement, and press 'Next' button.

6. Unselect Lisp Libraries if you don't want this optional component be installed, press 'Next' and then 'Finish' buttons to install Cusp and accept to restart Eclipse.

7. Note that SBCL is no longer provided through this update site. You will need to provide a version of CL. The Cusp should work with many CL distributions, however it is mostly tested with SBCL. SBCL distribution should be installed in Cusp plugin folder or it should be installed sitewide and correct value of SBCL_HOME should be specified. Compiled version of SBCL can be downloaded from its website. Once you download and unpack archive with correct version of binary package, read install file on how to install SBCL.

Note: If Cusp cannot find your lisp installation check Cusp FAQ.

News

Sep. 18, 2008 - Cusp (svn) 0.9.375 (zip archive only, not available through update site)
Sep. 16, 2008 - New (fixed) zip archive with Cusp 0.9.360
Sep. 15, 2008 - Cusp (svn) 0.9.360 (1.0 release candidate)
Aug. 16, 2008 - Cusp (svn) 0.9.245
Aug. 12, 2008 - Cusp (svn) 0.9.218